Scroll

Installation Troubleshooting

These are some common issues that may arise during an installation of Exago and some solutions for resolving them. If you are encountering problems that are not listed below, please file a support ticket.

 

An error has occurred. Please contact your administrator.

Append "?ShowErrorDetail=true" to the end of the URL, and try to replicate the behavior which caused the error. This will allow you to identify the error in more detail and search for a solution.

 

HTTP Error 500.19 - Internal Server Error

The configuration section 'standardEndpoints' cannot be read because it is missing a section declaration.

Most likely problem: Incorrect or missing Application Pool.

Solution: Select the correct Application Pool.

 

HTTP Error 403.14 - Forbidden

The Web server is configured to not list the contents of this directory.

Most likely problem: You're connecting to "http://[Exago]/" without specifying the home page or admin console.

Solution: Connect to "http://[Exago]/Admin.aspx" or "http://[Exago]/ExagoHome.aspx". OR set the IIS Default Document to "ExagoHome.aspx".

 

ERR_CONNECTION_REFUSED

Unable to connect.

Most likely problem: The Exago server or website is not running or the port is not open.

Solution: Restart the server and website. AND/OR add a firewall rule for the inbound http port.

 

Error: Access to the path 'C:\[Exago]\Config\WebReports.xml' is denied.

Most likely problem: Permissions are not set on the config folder.

Solution: Set the IIS user permissions to Full Control on the config folder.

 

Object reference not set to an instance of an object.

Most likely problem: Config file is missing or corrupt, or permissions are not set on the config folder.

Solution: Load the Admin console to generate a blank config file. If you continue to encounter the error, set the IIS user permissions to Full Control on the config folder.

 

Exception occured configuring log4net: Access to the path 'C:\[Exago]\Temp' is denied.

Most likely problem: Permissions are not set on the temp folder.

Solution: Set the IIS user permissions to Full Control on the temp folder.

 

Folder or Virtual Directory not found: path=[path], mappedPath=[path]

Most likely problem: Report folder path is wrong or permissions are not set on the report folder.

Solution: Verify the report path is set correctly in the Admin Console. Set the IIS user permissions to Full Control on the report folder.

 

Error saving report. Please contact your administrator.

Most likely problem: Permissions are not set on the report folder.

Solution: Set the IIS user permissions to Full Control on the report folder.

 

Session has timed out; browser page will need to be reloaded or browser restarted

Most likely problem: Exago is dropping sessions or web server is restarting unexpectedly.

Solution: Make sure the reports folder is located outside the Exago filesystem. You may need to configure a state service. Check for any disruptions in your web server's uptime.

 

My error is not listed above.

Please file a support ticket.


Hidden Article Information

Article Author
Exago Development
created 2017-01-19 17:20:36 UTC
updated 2017-01-19 21:19:29 UTC

Labels
Installation, Installing Exago, error, http, Install, IIS, Internal Server Error, state, session, timeout, 500.19, 403.14, Please contact your administrator,
Have more questions? Submit a request